Sign In   Register
Introduction
Pinned Items
Recent Activities
  • Mogwyth thanked the user talkingcars in the forum post, Engine bay fan
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Mogwyth thanked the user julianfoulger in the forum post, Engine bay fan
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Mogwyth thanked the user markvrs in the forum post, Engine bay fan
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Mogwyth created a new forum post in MGF/TF Pitstop
    Long time member, well several years, but first post. Engine bay fan has stopped working on my 02 160.

    Tried pulling the sensor nothing, tried new fan, replaced fuse and relay still nothing with sensor unplugged cant think of any other options apart from ECU!

    So apart from any bright suggestions on how to solve it, or quick temporary fix, OH is tearing her hair out as we are due to go to the lakes in a fortnight in it, question is with cooler weather and not ragging it any dangers in using it without the fan working?


    Cheers

    Bill
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Mogwyth updated his profile cover
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Mogwyth updated his profile picture
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Mogwyth updated his profile
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
There are no activities here yet
Unable to load tooltip content.
© 2022 The-T-Bar.com All Rights Reserved.