Sign In   Register
  • Page:
  • 1

Topic

Uneven running at low speed 1 week 6 days ago #205739

So my daily driver 2004 TF with 126,000 miles has developed the habit of running unevenly at low speed on deceleration/ overrun, jerking. Otherwise it is fine under load at normal speeds. I'm assuming for some reason the mixture is incorrect at low speed, hence the hunting?

As far as I am aware the injectors are original and haven't been inspected or cleaned in the 5 years I've had the car - could this be the cause of my problems? How long are the injectors expected to last? I recall reading that diesel injectors are anticipated to last 100,000 miles, do petrol injectors last a similar period?

Please Log in to join the conversation.

Uneven running at low speed 1 week 6 days ago #205743

Sounds like an idle/ Iacv problem. This should be useful IACV
David
:shrug:
The following user(s) said Thank You: Gavin207

Please Log in to join the conversation.

Last edit: Post by David Aiketgate.

Uneven running at low speed 1 week 6 days ago #205744

I had the injectors out of my car the other day. They are Bosch & the date code places them in the year the car was manufactured, 1998. It has covered in excess of 125000 miles. I have a crude test rig where I can clack the solenoid & pump pressurised IPA across the workshop, out of the door & down the courtyard, checking the spray pattern on its way past me.
IPA is isopropyl alcohol, not Indian pale ale. IPA flushed the injectors out, Indian PA might not be as effective.
So I would say yes petrol injectors last as long as diesel, providing the quality is there at the outset, even allowing for the electrical component.
I have a blue set, Bosch again, & the spray pattern is completely different. These are from a later MG tf.
M
The following user(s) said Thank You: Gavin207

Please Log in to join the conversation.

  • Page:
  • 1
Time to create page: 0.073 seconds
© 2024 The-T-Bar.com All Rights Reserved. Hosted By SEBS IT