2005 TF lost IDLE yesterday, after having drunk my coffee while at next village

  • VVC160
  • VVC160's Avatar Offline Topic Author
  • Time served MGer
  • Time served MGer
  • Van (not yet a camper) driver nowadays
  • Posts: 192
  • Thanks: 28
Heat wave issue (35°C)???????????? Stalling at once, but I could drive back home without too much trouble, foot kept on accelerator pedal...

Today, still no MIL light on, but feeling like one cylinder could be missing fire!!! Spark plug lead disconnected???
Stalling within 1 second, I mean!

I even feel unable to get out of the yard for a road test, alas. Much too hot today for any engine failure...

................
Last Edit:10 months 1 day ago by VVC160
Last edit: 10 months 1 day ago by VVC160. Reason: mod

Please Log in or Create an account to join the conversation.

Loss of spark on one cylinder will cause rough running may make it harder to start but wouldnt necessarily kill the ability to idle

Other than loss of idling how is the engine running. If you hold the pedal at say 1500 rpm does it run steadily and smoothly ?

2003 TF 135 sunstorm

Please Log in or Create an account to join the conversation.

  • VVC160
  • VVC160's Avatar Offline Topic Author
  • Time served MGer
  • Time served MGer
  • Van (not yet a camper) driver nowadays
  • Posts: 192
  • Thanks: 28
Hi, Thx 4 helping...Sending my cheap OBD 327 app report, just in case...The 1st was in March not much different than today, black oneJust had a try: - Yes, I can run steadily between 1000/1200
Last Edit:9 months 3 weeks ago by VVC160
Last edit: 9 months 3 weeks ago by VVC160. Reason: mod

Please Log in or Create an account to join the conversation.

Its worth using the Search feature to see idle problems encountered by others. Here are a couple, and it would be worth searching for more; see if any of these are the same as your symptoms

https://www.the-t-bar.com/forum/9-mgf-tf-pitstop/90197-unstable-idle

https://www.the-t-bar.com/forum/9-mgf-tf-pitstop/55392-low-idle-revs-nearly-to-point-of-stalling#55467


https://www.mgfregister.org/forum/viewtopic.php?t=1762

This one describes the idle control valve ; https://www.the-t-bar.com/forum/22-cjj-s-guides/26538-replacing-the-idle-air-control-valve-iacv

Its worth reading as much as you can. These cars have been around a while so most problems have been experienced and solved

2003 TF 135 sunstorm

Last Edit:10 months 18 hours ago by Notanumber
Last edit: 10 months 18 hours ago by Notanumber.

Please Log in or Create an account to join the conversation.

  • VVC160
  • VVC160's Avatar Offline Topic Author
  • Time served MGer
  • Time served MGer
  • Van (not yet a camper) driver nowadays
  • Posts: 192
  • Thanks: 28
I did read few pages since issue... IACV reset (when warm?!?), etc.
Not an unstable IDLE but none at all!

Being lazy (until I need to remove engine cover), I just asked myself if disconnecting the battery would help?!? No trouble except radio memory. Instead of trying an IACV reset from cold (even already tested)...
I did charged it thinking it was week (12,5V)...


I'm now guessing the alternator belt doesn't like starts & stops...
by VVC160

Please Log in or Create an account to join the conversation.

Has it made any difference to the idle when you disconnected and reconnected the battery then reset the IACV ?

2003 TF 135 sunstorm

Please Log in or Create an account to join the conversation.

  • VVC160
  • VVC160's Avatar Offline Topic Author
  • Time served MGer
  • Time served MGer
  • Van (not yet a camper) driver nowadays
  • Posts: 192
  • Thanks: 28
Battery at 13.6V after a night charge, but nothing better this morning...
Not able to get the engine warm for the IACV reset (tried "cold" anyway)......
by VVC160

Please Log in or Create an account to join the conversation.

  • VVC160
  • VVC160's Avatar Offline Topic Author
  • Time served MGer
  • Time served MGer
  • Van (not yet a camper) driver nowadays
  • Posts: 192
  • Thanks: 28
Took off engine cover this afternoon...
Only tried the little breather hoses disconnection...
One was effective. Too low & unstable revs (5000-9000) idle...
BUT, what does it mean?
Air filter wasn't too neat... Very thin clear dust covering the engine compartment.
At that point, not a huge work to have a check of the stepper motor...
I still wish to understand this lack of air flow somewhere...

Last Edit:9 months 4 weeks ago by VVC160
Last edit: 9 months 4 weeks ago by VVC160.

Please Log in or Create an account to join the conversation.

Well done for getting this far. Definitely replace the air filter. if it is dirty it will restrict performance and complicate your fault finding.

2003 TF 135 sunstorm

Last Edit:9 months 4 weeks ago by Notanumber
Last edit: 9 months 4 weeks ago by Notanumber.

Please Log in or Create an account to join the conversation.

  • VVC160
  • VVC160's Avatar Offline Topic Author
  • Time served MGer
  • Time served MGer
  • Van (not yet a camper) driver nowadays
  • Posts: 192
  • Thanks: 28
No change coming from new air filter, though!


And disconnecting IACV plug or manifold air pressure sensor <=> stalling
Last Edit:9 months 3 weeks ago by VVC160
Last edit: 9 months 3 weeks ago by VVC160.

Please Log in or Create an account to join the conversation.

  • VVC160
  • VVC160's Avatar Offline Topic Author
  • Time served MGer
  • Time served MGer
  • Van (not yet a camper) driver nowadays
  • Posts: 192
  • Thanks: 28
Wondering if my tools are sensibly efficient...
by VVC160

Please Log in or Create an account to join the conversation.

  • VVC160
  • VVC160's Avatar Offline Topic Author
  • Time served MGer
  • Time served MGer
  • Van (not yet a camper) driver nowadays
  • Posts: 192
  • Thanks: 28
spring stop screw setting?
Unsuccessful attempts...
by VVC160

Please Log in or Create an account to join the conversation.

Time to create page: 0.493 seconds