Sign In   Register
Introduction
Pinned Items
Recent Activities
  • legsakimbo created a new forum post in MGF/TF Pitstop
    Well after a few problems, I managed to get the "F" started,

    Ticks over and revs up OK.

    The problem now is when it is cold it will only start with a "Sniff" of Easy Start, once started and warmed up it will start OK.

    Any ideas as to why it does this??
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Hello, Looking for the Cam sensor, The car is an MGF with a Dizzy Cap. (MGF MPI?) It shows in your post that it is located on the exhaust side of the cam shaft cover,,,But NOT on my engine, Do you have any idea where it could be located? And would a faulty sensor stop the car from starting? Or would that be likley the Crank Shaft sensor?.

    Waiting in anticipation.

    Regards

    John
    1. View Reply
    2. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • legsakimbo created a new forum post in MGF/TF Pitstop
    Well I put the car (MGF MPi) in the garage a month ago,,, went to it yesterday engine spins over but show no sign of life, although there was a strong smell of petrol it failed to start.

    I have a good spark at the plugs, and recent new dissy cap leads and plugs.

    Fuel pump works when ignition on and shuts off after a few seconds.

    Any suggestions as where to start looking?
    1. View Thread →
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
There are no activities here yet
Unable to load tooltip content.
© 2023 The-T-Bar.com All Rights Reserved. Hosted By SEBS IT