Sign In   Register
  • Page:
  • 1

Topic

Rover 800 T16 1 year 2 months ago #195501

Hi, I was reading an old entry on the Rover 800 forum, and Philip was talking about being unsure of the compatibility of pscan with Rover 800s (especially post 96).

I was just wondering if this was ever resolved?

Thanks - hope to speak soon

Please Log in to join the conversation.

Rover 800 T16 1 year 2 months ago #195502

pscan appears to work with all of the Engine ECUs except for the Honda ones.

The ones that I have identified:-
T16: MEMS1.6, tested and works (needs 3 pin cable)
KV6 2.5: MEMS2J, tested and works
T-series non turbo: MEMS1.9 tested and works

I believe that the older 4 cylinder cars are using MEMS1.3 or MEMS1.6 and they will almost certainly work.  I tried a Montego ECU and that worked and they look similar.

Honda ECUs are not going to work (yet).  I think I have a Honda ECU from a 620 but I haven't had a chance to try it out.
 

Please Log in to join the conversation.

Rover 800 T16 1 year 2 months ago #195505

Ah, that's interesting.

I have a '98 T16 turbo (820 Vitesse) and curious about what I would need.

Please Log in to join the conversation.

Rover 800 T16 1 year 2 months ago #195509

For a T16 turbo you need a pscan and the optional 3 pin cable.

The T16 turbo ECU is well tested and supported as I have one of these ECUs in the lab.
The following user(s) said Thank You: mercedade, alouroverPT

Please Log in to join the conversation.

Rover 800 T16 1 week 6 days ago #199257

hello... i need the instructioon sto plug the optional cable and to teste these options... and where can i find the 3 pin plug in the engine bay? thanks

Please Log in to join the conversation.

Rover 800 T16 1 week 17 hours ago #199344

Are any 800 owners able to assist? I only have an ECU, not an actual car.

Please Log in to join the conversation.

  • Page:
  • 1
Moderators: pscan.uk
Time to create page: 0.083 seconds
© 2022 The-T-Bar.com All Rights Reserved. Hosted By SEBS IT